Keyboard shortcuts
To | Press
Close the Navigator | ALT+F4
Switch between the Navigator and other open windows. | ALT+TAB
Display the Options menu. | ALT+O
Change Microsoft Internet Explorer settings. The Internet Options dialog box contains accessibility settings. To change these settings click the General tab, and then click Accessibility. | ALT+O, and then press I
Hide or show the Navigation pane. | ALT+O, and then press T
Print a topic. | ALT+O, and then press P, or right-click in the topic pane
Move back to the previous topic. | ALT+LEFT ARROW, or ALT+O, and then press B
Move forward to the next topic (provided you have viewed it just previously). | ALT+RIGHT ARROW, or ALT+O, and then press F
Turn on or off search highlighting. | ALT+O, and then press O
Refresh the topic that appears in the Topic pane (this is useful if you have linked to a Web page). | F5, or ALT+O, and then press R
Return to the Home page. | ALT+O, and then press H
Stop the Navigator from opening a page (this is also useful if you are linking to the Web and want to stop a page from downloading). | ALT+O, and then press S
Jump to Contents (1) or ETSIWeb (2). | ALT+O, and then press 1 or 2
Switch between the Navigation pane and the Topic pane. | F6
Scroll through a topic. | UP ARROW and DOWN ARROW, or PAGE UP and PAGE DOWN
Scroll through all the links in a topic or through all the options on a Navigation pane tab. | TAB

For the Contents tab:

To | Press
Display the Contents tab. | ALT+C
Open and close a book or folder. | PLUS SIGN and MINUS SIGN, or LEFT ARROW and RIGHT ARROW
Select a topic. | DOWN ARROW and UP ARROW
Display the selected topic. | ENTER

For the Index tab:

To | Press
Display the Index tab. | ALT+N
Type a keyword to search for. | ALT+W, and then type the word
Select a keyword in the list. | UP ARROW and DOWN ARROW
Display the associated topic. | ALT+D

For the Search tab:

To | Press
Display the Search tab. | ALT+S
Type a keyword to search for. | ALT+W, and then type the word
Start a search. | ALT+L
Select a topic in the results list. | ALT+T, and then UP ARROW and DOWN ARROW
Display the selected topic. | ALT+D

NOTE: Every time you use a shortcut key in the Navigation pane, you lose focus in the Topic pane. To return to the Topic pane, press F6.


Free-standing version of the ETSI drafting rules

ETSI Drafting Rules (EDRs) navigator
April 2013 edition

editHelp! editing assistance http://portal.etsi.org/edithelp/home.asp


ETSI drafting rules - Information

Information
ETSI: | 650 Route des Lucioles
 | F-06921 Sophia Antipolis Cedex - FRANCE
Tel: | +33 4 92 94 42 00
Fax: | +33 4 93 65 47 16

Siret N° 348 623 562 00017 - NAF 742 C
Association à but non lucratif enregistrée à la Sous-Préfecture de Grasse (06) N° 7803/88

Important notice:

Individual copies of the ETSI drafting rules can be downloaded from editHelp!

The present document may be made available in more than one electronic version or in print. In any case of existing or perceived difference in contents between such versions, the reference version is the Portable Document Format (PDF).
In case of dispute, the reference shall be the printing on ETSI printers of the PDF version kept on a specific network drive within ETSI Secretariat.

Users of the present document should be aware that the document may be subject to revision or change of status. Information on the current status of this and other ETSI documents is available at http://portal.etsi.org/tb/status/status.asp

If you find errors in the present document, please send your comment to edithelp@etsi.org

Copyright Notification:

No part may be reproduced except as authorized by written permission.
The copyright and the foregoing restriction extend to reproduction in all media.

© European Telecommunications Standards Institute 2013.
All rights reserved.


ETSI drafting rules - Foreword

Foreword

The ETSI Secretariat provides guidance on the drafting of ETSI deliverables via its editHelp! function. The service consists of on-line help, available via:

  • http://portal.etsi.org/edithelp/home.asp

and personal advice, can be obtained from:

  • e-mail: edithelp@etsi.org
  • tel: +33 4 92 94 43 43 or
  • fax: +33 4 93 38 52 61

NOTE: Wherever editHelp! is mentioned in the present document (click on it), further information can be found on the web site.

Items concerning word-processor specific layout and formatting matters when using the Microsoft® Word based ETSI skeleton documents and templates are shown with shaded background. Boiler plate text (i.e. text which shall be directly used in ETSI deliverables) is represented by italic characters.

ETSI stresses the importance of the quality of inputs sent to the ETSI Secretariat by Rapporteurs: documents which are corrupted, badly formatted or not conforming to the ETSI drafting rules considerably increase the amount of time necessary to release and/or publish deliverables.


ETSI drafting rules - Scope

1 Scope

The present document specifies rules for the structure and drafting of documents intended to become ETSI deliverables. These rules complement the ETSI Technical Working Procedures (TWP) ( http://portal.etsi.org/Directives/home.asp) and are intended to ensure that such documents are drafted in as uniform a manner as is practicable, irrespective of the technical content.


ETSI drafting rules - Scope

2 References

References are either specific (identified by date of publication and/or edition number or version number) or non specific. For specific references, only the cited version applies. For non-specific references, the latest version of the reference document (including any amendments) applies.

Referenced documents which are not found to be publicly available in the expected location might be found at http://docbox.etsi.org/Reference.

NOTE: While any hyperlinks included in this clause were valid at the time of publication ETSI cannot guarantee their long term validity.

2.1 Normative references

The following referenced documents are necessary for the application of the present document.

Not applicable.

2.2 Informative references

The following referenced documents are not necessary for the application of the present document but they assist the user with regard to a particular subject area.

i.1 | ETSI Directives: "ETSI Statutes; ETSI Rules of Procedure; ETSI Board Working Procedures; Powers and Functions of the Board; Terms of Reference of the Operational Co ordination Group (OCG); ETSI Technical Working Procedures; ETSI Drafting rules".
i.2 | ETSI TCR-TR 006: "Methods for Testing and Specification (MTS); ETSI and certification in telecommunications; Overview of outstanding issues and some recommendations".


ETSI drafting rules - Definitions

3 Definitions and abbreviations
3.1 Definition

For the purposes of the present document, the terms and definitions given in the ETSI Directives [i.1] and the following apply:

bibliography: list of standards, books, articles, or other sources on a particular subject which are not mentioned in the document itself

deliverable: ETSI document, established by consensus and approved by a recognized body, that provides, for common and repeated use, rules, guidelines or characteristics for activities or their results, aimed at the achievement of the optimum degree of order in a given context

informative element: provides additional information intended to assist the understanding or use of the ETSI deliverable, but which can be removed without changing its technical substance

informative reference: not essential to the use of the ETSI deliverable but that assist the user with regard to a particular subject area

NOTE: Informative references mentioned in the document itself are numbered and listed in clause 2.2 (References) otherwise they are listed in an annex entitled "Bibliography".

informative reference clause: clause listing informative references cited in the document which are not necessary for its application but assist the user with regard to a particular subject area

instruction: provision that conveys an action to be performed (ISO/IEC Guide 2: 1996, definition 7.3)

normative element: sets out the provisions to which it is necessary to conform in order to be able to claim compliance with the ETSI deliverable

normative reference: essential to the use of the ETSI deliverable, i.e. without which the deliverable cannot be implemented

normative reference clause: clause listing normative references cited in the document which are necessary for its application

NOTE: For specific references, each shall be given with its year of publication or, in the case of enquiry with its year of issue, and full title. The year of publication or year of issue shall not be given for non-specific references. When a non-specific reference is to all parts of a document, the publication number shall be followed by the indication "(all parts)" and the general title of the series of parts.

provision: expression in the content of an ETSI deliverable, that takes the form of a statement, an instruction, a recommendation or a requirement

NOTE: These types of provision are distinguished by the form of wording they employ; e.g. instructions are expressed in the imperative mood, recommendations by the use of the auxiliary "should" and requirements by the use of the auxiliary "shall" (see clause 14a).

publicly available: in the context of referencing documents within ETSI deliverables, a document that may be obtained from the source organization or its distribution channels by any person (with or without payment), simply by quoting the reference given in the ETSI deliverable to the source organization or other typical supplier (e.g. National Standards Organization, Library, etc.)

NOTE: ETSI deliverables are made publicly available during the various stages of the relevant approval procedures prior to publication and at the point of publication. Thus, for ETSI deliverables, public availability is a broader concept than publication. The specific status of a publicly available ETSI deliverable may be determined by examining its History clause.

This may also be true of other standardization bodies whose documents are referenced by ETSI and this is taken into account during the preparation of ETSI deliverables.

EXAMPLE: A Public Enquiry version of an ETSI deliverable is made publicly available by ETSI and, therefore, fulfils the above definition.

published: specific case of public availability for an ETSI deliverable, occurring when all relevant approval procedures have been successfully completed

NOTE: A published deliverable may be identified by examining the History clause of the document in question. The last line in the History box will contain the word "Publication".

recommendation: expression in the content of a document conveying that among several possibilities one is recommended as particularly suitable, without mentioning or excluding others, or that a certain course of action is preferred but not necessarily required, or that (in the negative form) a certain possibility or course of action is deprecated but not prohibited

NOTE: Table "4" specifies the verbal forms for the expression of recommendations.

requirement: expression in the content of a document conveying criteria to be fulfilled if compliance with the document is to be claimed and from which no deviation is permitted

NOTE: Table "3" specifies the verbal forms for the expression of requirements.

standard: document, established by consensus and approved by a recognized body, that provides, for common and repeated use, rules, guidelines or characteristics for activities or their results, aimed at the achievement of the optimum degree of order in a given context

statement: provision that conveys information (ISO/IEC Guide 2: 1996, definition 7.2)


ETSI drafting rules - Abbreviations

3.2 Abbreviations

For the purposes of the present document, the following abbreviations apply:

ASCII | American Standard Code for Information Interchange
ASN.1 | Abstract Syntax Notation no. 1
CIF | Common Interchange Format
EDRs | ETSI Drafting Rules
EN | European Standard
EG | ETSI Guide
ES | ETSI Standard
ETS | European Telecommunication Standard
GDMO | Guidelines for the Definition of Managed Objects
GR | Graphical Rendition
GS | ETSI Group Specification
HMSC | High level MSC
ICS | Implementation Conformance Statement
IPR | Intellectual Property Rights
LVD | Low Voltage Directive
MP | Machine Processable
MSC | Message Sequence Charts
NSO | National Standards Organisation
OJEU | Official Journal of the European Union
PDF | Portable Document Format
R&TTE | Radio equipment & Telecommunications Terminal Equipment
SDL | Specification and Description Language
SDT | SDL Development Tool
SR | ETSI Special Report
TB | ETSI Technical Body
TC | ETSI Technical Committee
TR | ETSI Technical Report
TS | ETSI Technical Specification
TTCN | Testing and Test Control Notation
TTCN | Tree and Tabular Combined Notation
NOTE: The introduction of TTCN-3 led to a name change from Tree and Tabular Combined Notation to Testing and Test Combined Notation. It shall be made clear in each ETSI deliverable which version of TTCN applies.
TWP Technical Working Procedures


General principles - Objective

4 General principles
4.1 Objective

The objective of an ETSI deliverable is to define clear and unambiguous provisions in order to facilitate international trade and communication. To achieve this objective, the ETSI deliverable shall:

 be as complete as necessary within the limits specified by its scope;
be consistent, clear and accurate;
provide a framework for future technological development; and
be comprehensible to qualified persons who have not participated in its preparation.


General principles - Homogeneity

4.2 Homogeneity

Uniformity of structure, of style and of terminology shall be maintained not only within each ETSI deliverable, but also within a series of associated ETSI deliverables. The structure of associated ETSI deliverables and the numbering of their clauses shall, as far as possible, be identical. Analogous wording shall be used to express analogous provisions; identical wording shall be used to express identical provisions.

The same term shall be used throughout each ETSI deliverable or series of ETSI deliverables to designate a given concept. The use of an alternative term (synonym) for a concept already defined shall be avoided. As far as possible, only one meaning shall be attributed to each term chosen.

These requirements are particularly important not only to ensure comprehension of the ETSI deliverable but also to derive the maximum benefit available through automated text-processing techniques.


General principles - Consistency of ETSI deliverables

4.3 Consistency of ETSI deliverables

In order to achieve the aim of consistency within the complete body of ETSI deliverables, the text of every ETSI deliverable shall be in accordance with the relevant provisions of existing basic ETSI deliverables. This relates particularly to:

  • standardized terminology;
  • principles and methods of terminology;
  • quantities, units and their symbols;
  • abbreviations;
  • tables and figures numbering;
  • bibliographic references; and
  • graphical symbols.

In addition, for specific technical aspects, the relevant provisions of general ETSI deliverables dealing with the following subjects shall be respected:

  • limits;
  • tolerance of dimensions and uncertainty of measurement;
  • preferred numbers;
  • statistical methods; and
  • environmental conditions and associated tests.


General principles - Equivalence of official language versions

4.4 Equivalence of official language versions

ETSI deliverables shall be in the English language only.


General principles - Fitness for implementation as a national, regional or international standard

4.5 Fitness for implementation as a national, regional or international standard

The content of an ETSI deliverable shall be drawn up in such a way as to facilitate its direct application and its adoption without change as a national, regional or international standard (see ETSI Rules of Procedure, article 13.7).


General principles - Planning

4.6 Planning

Rules for the planning of new work items are given in the ETSI Directives [i.1]. When creating a new work item, it is useful to consider whether the end result will be one or more ETSI deliverables (for example, a multi-part standard). In the case where multiple deliverables are expected, some thought should be given to the intended structure and any interrelationships between the various components as this facilitates work planning in both the Technical Body (TB) and in the Secretariat.

In the case of a multi-part ETSI deliverable, a list of the intended parts together with their titles should be drawn up. The drafting rules given in the present document shall be applied from the very beginning of the work and throughout all subsequent stages to avoid delay at any stage.


General principles - Legal master of an ETSI deliverable

4.7 Legal master of an ETSI deliverable

ETSI deliverables are made publicly available by ETSI in PDF format. Other formats may also be available.

From a legal point of view, the official version of a document is the one which is recognized by the author as being the definitive and mature version of his/her work at a certain date. The official version of a document constitutes a reference from which it is possible to identify that amendments have been made.

In ETSI, the definitive version of an ETSI deliverable (until further amendments are made) is the one that has been checked by the Secretariat and incorporates the amendments resulting from the approval process prescribed for the ETSI deliverable in the Technical Working Procedures (TWPs). The official version of the ETSI deliverable is the electronic PDF file kept in ETSI.


Structure - Subdivision of the subject matter - General

5 Structure
5.1 Subdivision of the subject matter
5.1.1 General

ETSI deliverables are so diverse that no universally acceptable rules can be established for the subdivision of the subject matter.

However, as a general rule, an individual ETSI deliverable shall be prepared for each subject to be standardized and published as a complete entity. In specific cases and for practical reasons, for example:

 the ETSI deliverable is likely to become too voluminous;
subsequent portions of the content are interlinked;
portions of the ETSI deliverable could be referred to in regulations; or
portions of the ETSI deliverable are intended to serve for certification purposes:
the ETSI deliverable may be split into separate parts under the same number. This has the advantage that each part can be changed separately when the need arises.

In particular, the aspects of a product which will be of separate interest to different parties (e.g. manufacturers, operators, certification bodies, legislative bodies) shall be clearly distinguished, preferably as parts of an ETSI deliverable or as separate ETSI deliverables.

Such individual aspects are, for example:

  • performance requirements;
  • maintenance and service requirements; and
  • quality assessment.

The terms that shall be used to designate the divisions and subdivisions that an ETSI deliverable may have are shown in table 1.

Table 1: Names of divisions and subdivisions

Term | Example of numbering
part sub-part clause clause clause annex clause clause paragraph subclause | ES 201 111-1 ES 201 111-1-2 1 1.1 1.1.1 A A.1 A.1.1

NOTE: The use of terms " paragraph" and "subclause" is authorized in "exceptional cases" (e.g. where the ETSI Drafting Rules, if applied, would change the meaning of the sentence or make it difficult to understand).
EXAMPLE: "... is described in the remaining subclauses of this clause".


Structure - Subdivision of the subject matter within a series of parts

5.1.2 Subdivision of the subject matter within a series of parts

There are two systems in use for subdividing into parts:

a) | Each part deals with a specific aspect of the subject and can stand alone.
b) | There are both common and specific aspects to the subject. The common aspects shall be given in part 1. Specific aspects (which may modify or supplement the common aspects and, therefore, cannot stand alone) shall be given in individual parts.

Where the system described in b) is used, care shall be taken that the references from one part to another are always to the appropriate version. There are two ways to achieve this:

If reference is made to a particular element, the reference shall be specific (see clause 12.3).

Since the complete series of parts is normally under the control of the same Technical Body, the use of non‑specific references (see clause 12.4) is permitted, provided that corresponding changes are implemented simultaneously in all parts.

The use of non-specific references requires a high degree of discipline by the Technical Body responsible for the ETSI Deliverable.


Structure - Subdivision of the subject matter within an individual ETSI deliverable

5.1.3 Subdivision of the subject matter within an individual ETSI deliverable

Table 2: Example of a typical arrangement of elements in an ETSI deliverable
Type of element | Arrangement of elements in an ETSI deliverable (note) | Permitted content of element(s) in an ETSI deliverable (note) | Reference
Informative preliminary | Title page | Title | clause 6
 | Table of contents | (generated content) | clause 7
 | Intellectual Property Rights Foreword Transposition (ENs only) | Text Note(s) Table | clause 8 clause 9 clause 9a
 | Introduction | Text Figure(s) Table(s) Note(s) | clause 10
Informative general
 | Scope Reference(s) Definition(s) Symbol(s) and abbreviation(s) | Text Figure(s) Table(s) Note(s) Reference(s) | clause 11 clause 12
Normative general | Reference(s) | Reference(s) | clause 12
Normative technical | Requirements Normative annex | Text Figure(s) Table(s) Note(s) | clause 14a clause 15 clause 16.2
Informative supplementary | Informative guidance Informative annex | Text Figure(s) Table(s) Note(s) | clause 16.3
 | Bibliography | Informative reference(s) and reading material | clause 17
 | Index | (generated content) | clause 18
 | History | Table | clause 19
NOTE: Bold type = required element; upright type = normative element; italic type = informative element.

An ETSI deliverable need not contain all the normative technical elements shown in table 2 and it may contain normative technical elements other than those shown. Both the nature of the normative technical elements and their sequence are determined by the nature of the ETSI deliverable in question.

An ETSI deliverable may also contain notes to figures and tables (see clauses 20.3.1 and 20.3.2).


Structure - Parts and sub-parts

5.2 Description and numbering of divisions and subdivisions
5.2.1 Parts and sub-parts

The number of a part shall be indicated by Arabic numerals, beginning with 1 (limited to 2 digits), following the ETSI deliverable number and preceded by a hyphen, for example:

  • ES 201 999-1, ES 201 999-2, EN 300 356-33, EN 300 356-34.

The number of a sub-part shall be indicated by Arabic numerals, beginning with 1-1 (limited to 2 digits), following the ETSI deliverable number and preceded by a hyphen, for example:

  • ES 201 999-1-1, ES 201 999-1-2, EN 300 356-33-10, EN 300 356-33-11.


Structure - General numbering issues

5.2.1a General numbering issues

The "IPR" clause, the "Foreword" clause and the "Introduction" clause (optional) shall be unnumbered.

The clauses in each ETSI deliverable shall be numbered with Arabic numerals, beginning with 1 for the "Scope".

Every attempt shall be made to use continuous numbering. However, if continuous numbering cannot be maintained, a new element shall be inserted in existing text using an appropriate alphanumeric designation that does not disturb the existing numbering scheme. This applies to all elements (e.g. clause, annex, figure, table, note, list).

EXAMPLE 1: | It is necessary to update an ETSI deliverable. A new clause needs to be inserted between the existing clauses 8 and 9. A new clause 8a shall be inserted in preference to avoid re-numbering the existing clauses.
EXAMPLE 2: | A new figure needs to be inserted between existing figures 4 and 5. A new figure 4a shall be inserted to avoid re-numbering of all subsequent figures.

Similarly, an existing element may be deleted and replaced with the term "Void" to minimize disruption to the numbering scheme.

EXAMPLE 3: | During the updating of an ETSI deliverable, it is decided that annex C is no longer required. The title of annex C becomes "Void". Later annexes shall, therefore, remain unchanged.
EXAMPLE 4: | It is decided to delete a note 3, so the text of note 3 becomes "Void." and there is no need to renumber note 4.


Structure - Clause

5.2.2 Clause

Each clause shall have a title which shall be placed after its number (except "IPR", "Foreword" and "Introduction" clauses, which are unnumbered), separated by a tab.

A clause can have numbered subdivisions, e.g. 5.1, 5.2, 5.1.1, 5.1.2, etc. This process of subdivisions may be continued as far as the sixth heading level (e.g. 6.5.4.3.2.1).

For numbering, see clause 5.2.1a.

  • Use the Heading style appropriate to its level (see table A.1).
  • Separate the number of the heading and the text of the heading with a tab.
  • Treat clause titles as normal text (i.e. no additional capitalization), but no full stop.


Structure - Automatic numbering

5.2.3 Automatic numbering

Automatic numbering may now be used in ETSI deliverables.

It is highly recommended to use sequence numbering (see clause A.4) to avoid problems when the deliverable will be converted to PDF format.


Structure - Paragraph

5.2.4 Paragraph

A paragraph is an unnumbered subdivision of a clause.

"Hanging paragraphs" such as those shown in the following example should be avoided when reference to them is ambiguous.

EXAMPLE 1: In the following example the hanging paragraphs indicated cannot be uniquely identified as being in "clause 5" since strictly speaking the paragraphs in clauses 5.1 and 5.2 are also in clause 5. To avoid this problem it would be necessary either to identify the unnumbered paragraphs as clause "5.1 Xxxxxxxxxxxx" and to renumber the existing 5.1 and 5.2 accordingly (as shown), or to move the hanging paragraphs elsewhere.

Recommended
5 Title

5.1 Title

This text can be referred to without any ambiguity.

5.2 Title

This text can also be referred to without any ambiguity.

5.3 Title

This text can also be referred to without any ambiguity.

6 Test report

Not recommended
5 Title

This text cannot be referred to }

in a precise manner as clause 5 } hanging paragraphs

also has subdivisions }

5.1 Xxxxxxxxxxx

This text can be referred to without any ambiguity.

5.2 Xxxxxxxxxxx

This text can also be referred to without any ambiguity.

6 Test report
EXAMPLE 2: In the following example an acceptable hanging paragraph is shown.
Acceptable
5 Title

The following clauses define aaa, bbb and ccc (see note).

5.1 aaa

This text about "aaa" can be referred to without any ambiguity.

5.2 bbb

This text about "bbb" can be referred to without any ambiguity.

6 Test report
NOTE: There is no need for reference to this text.


Structure - Lists

5.2.5 Lists

Lists may be introduced by a sentence, a complete grammatical proposition or by the first part of a proposition, completed by the items in the list.

Each item in a list shall be preceded by a bullet, a dash, an Arabic numeral followed by a parenthesis, or a lower case letter followed by a parenthesis.

EXAMPLE 1:

  • list item 1
  • list item 2
  • list item 3

EXAMPLE 2:

- list item 1

- list item 2;

- list item 3.

EXAMPLE 3:

  • list item 1,
  • list item 2,
  • list item 3.

EXAMPLE 4:

1) List item 1

2) List item 2

3) List item 3

EXAMPLE 5:

a) List item a.

b) List item b.

c) List item c.

EXAMPLE 6:

  • list item 1

- list item 2

  • list item 3

NOTE: See table A.1 for different list styles.

If punctuation is used, the following rules shall be respected:

 If the elements of a list are cast as phrases of a sentence which introduces the list, each element shall start with a lower case letter and end with a semicolon. The last item in the list shall end with a full stop, unless the introductory sentence continues after the end of the list, in which case the most appropriate punctuation (semicolon, comma, or none) shall be used.
If, however, each element of a list is a self-contained sentence, each shall begin with a capital letter and end with a full-stop.

"And" or "or" shall be used at the end of the penultimate element of a list to indicate unambiguously whether all the elements apply ("and") or whether they are mutually exclusive ("or").

 Use the appropriate bullet styles, i.e. styles B1 to B5 or B1+ to B3+, BN, BL (see table A.1).
Separate the list item identifier (e.g. bullet) and the text with a tab (if using styles B1 to B5, the others are automatic bullet styles containing the space).
Ensure that the formatting of the lists is consistent throughout the deliverable.


Contents of the title page

6 Contents of the title page

The title page shall contain the title of the ETSI deliverable.

The wording of the title shall be established by the Technical Body with the greatest care. While being as concise as possible, it shall indicate, without ambiguity, the subject matter of the ETSI deliverable in such a way as to distinguish it from that of other ETSI deliverables, without going into unnecessary detail. Any necessary additional particulars shall be given in the scope.

The title shall be composed of separate elements, each as short as possible, proceeding from the general to the particular. In general, not more than the following three elements should be used:

a) | an introductory element (optional) indicating the general field to which the ETSI deliverable belongs; it should not be based on the name of the Technical Body which drafted the deliverable, especially if this is too broad to add much value;
b) | a main element (obligatory) indicating the principal subject treated within that general field;
c) | a complementary element (optional) indicating the particular aspect of the principal subject or giving details that distinguish the ETSI deliverable from other ETSI deliverables, or other parts of the same ETSI deliverable.

The ETSI Secretariat is responsible for the final preparation of the title page.

For multi-part deliverables, all the individual titles in a series of parts shall contain the same introductory element (if present) and main element, while the complementary element shall be different in each case in order to distinguish the parts from one another. The complementary element shall be preceded in each case by the designation "Part …:" and "Sub-part ...:".

For endorsement of documents from other standards organizations, see annex C.


Table of contents

7 Table of contents

The table of contents shall be generated automatically and shall not be set manually. The title shall be "Contents".

  • Use the TT style for the title.
  • Use the field {TOC \o\w} for the table itself.

Tables of contents for figures and/or tables are also allowed. If present, they shall appear as the last elements (or just before the index if any), before the "History" clause. The titles shall be "List of figures" and/or "List of tables".

  • Use the TT style for the title.

  • Use the field {TOC \t "TF" \c} for the list of figures and the field {TOC \t "TH" \c} for the list of tables.

NOTE 1: The ETSI Secretariat is responsible for the final layout of the table of contents.

NOTE 2: To unlock the table of contents, click simultaneously: Ctrl + Shift + F11. To lock it, click simultaneously: Ctrl + F11.


Intellectual Property Rights (IPRs)

8 Intellectual Property Rights (IPRs)

The Intellectual Property Rights (IPR) clause in an ETSI deliverable is always the first unnumbered clause. The following wording shall appear:

IPRs essential or potentially essential to the present document may have been declared to ETSI. The information pertaining to these essential IPRs, if any, is publicly available for ETSI members and non-members, and can be found in ETSI SR 000 314: "Intellectual Property Rights (IPRs); Essential, or potentially Essential, IPRs notified to ETSI in respect of ETSI standards", which is available from the ETSI Secretariat. Latest updates are available on the ETSI Web server (http://webapp.etsi.org/IPR/home.asp).

Pursuant to the ETSI IPR Policy, no investigation, including IPR searches, has been carried out by ETSI. No guarantee can be given as to the existence of other IPRs not referenced in ETSI SR 000 314 (or the updates on the ETSI Web server) which are, or may be, or may become, essential to the present document.


Foreword in an ETSI deliverable

9 Foreword in an ETSI deliverable

The "Foreword" clause in an ETSI deliverable is always the second unnumbered clause and on the same page as the IPRs.

The "Foreword" shall appear in each ETSI deliverable. It shall not contain requirements, figures or tables, except for the transposition table (see clause 9a).

It shall always contain a general part, provided by the ETSI Secretariat, giving information on:

 the designation and name of the Technical Body that prepared the ETSI deliverable; and
information regarding the approval of the ETSI deliverable.

Optionally, a specific part of the Foreword may be provided by the Technical Body giving as many of the following as are appropriate:

 an indication of any other organization that has contributed to the preparation of the ETSI deliverable;
a statement that the ETSI deliverable cancels and replaces other documents in whole or in part;
a statement of significant technical changes from the previous version of the ETSI deliverable;
the relationship of the ETSI deliverable to other ETSI deliverables or other documents;
the existence of an electronic attachment accompanying the ETSI deliverables, if this is not mentioned elsewhere.

For multi-part deliverables, there are two options for explaining the relationship between the various parts in the series. Either:

  1. the first part shall include in its foreword an explanation of the intended structure of the series. In the "Foreword" of each part belonging to the series, a reference shall be made to the titles of all other parts, if they are known;

  2. a specific part (part 1) shall provide an explanation of the intended structure of the series, together with details of the titles, version numbers, etc. of the various parts and sub-parts. Each time a new part or sub-part of the deliverable is made publicly available, the Secretariat shall publish a new version of part 1 showing the details of the new document.

Option b. is the preferred option.


Transposition table

9a Transposition table

Each European Standard (EN) shall contain a transposition table as the last element in the Foreword. This element is provided by the Secretariat and its purpose is described in the ETSI Technical Working Procedures, clause 2.4.


Executive Summary of an ETSI deliverable

10 Executive Summary of an ETSI deliverable

The "Executive Summary" is an optional preliminary element used, if required, to summarize the ETSI deliverable. It contains enough information for the readers to become acquainted with the full document without reading it. It is usually one page or shorter. It shall not contain requirements.


Introduction in an ETSI deliverable

10a Introduction in an ETSI deliverable

The "Introduction" is an optional preliminary element used, if required, to give specific information or commentary about the technical content of the ETSI deliverable, and about the reasons prompting its preparation. It shall not contain requirements.

The "Introduction" shall appear after the "Foreword" and "Executive Summary" (if used) and not be numbered unless there is a need to create numbered subdivisions. In this case, it shall be numbered 0 with clauses being numbered 0.1, 0.2, etc. Any numbered figure, table or displayed formula shall be numbered normally beginning with 1 (see also clause 5.2.1a).


Scope in an ETSI deliverable

11 Scope in an ETSI deliverable

This element shall start on a new page and be clause number 1 of each ETSI deliverable and define without ambiguity the subject of the ETSI deliverable and the aspect(s) covered, thereby indicating the limits of applicability of the ETSI deliverable or particular parts of it. It shall not contain requirements.

In deliverables that are subdivided into part, the scope of each part shall define the subject of that part of the deliverable only.
The "Scope" shall be succinct so that it can be used as a summary for bibliographic purposes.

This element shall be worded as a series of statements of fact. Forms of expression such as the following shall be used:

"The present document

- specifies | the functional requirements for …"
 | a method of …"
 | the characteristics of …"
- establishes | a system for …"
 | general principles for …"
- gives guidelines for …"
- gives terms and definitions …"

Statements of applicability of the ETSI deliverable shall be introduced by the following wording:

"The present document is applicable to …"


References in an ETSI deliverable

12 References in an ETSI deliverable
12.0 General

The References clause shall be clause 2 of an ETSI deliverable.

References shall be provided if normative references are made to other documents. Reproduction of elements from other documents is deprecated (i.e. referencing is the preferred method in ETSI).

Normative referencing of other documents is allowed under the following condition:

 all documents shall be publicly available in the English language during the approval phases and for the duration of the expected lifespan of the ETSI deliverable, via the originating body or via the ETSI Secretariat.
NOTE: If public availability of a referenced document cannot be guaranteed after publication of the ETSI deliverable has occurred, the originating body of the referenced document shall be requested to provide ETSI with the right to make the text available; the ETSI Secretariat shall establish and maintain a list of the referenced documents and the relevant external bodies, for document tracking and cross-referencing purposes, and keep the necessary liaison with the originating body.

Normative references mentioned in the body of the ETSI deliverable shall be listed in clause 2.1 (see normative references clause).

Normative references list shall contain:

 the issuing organization;
the document identity;
the edition or version number or date of publication (for Harmonized Standards, see clause 12.3);
the title.

The list shall not include the following:

referenced documents which are not publicly available;
referenced documents which are only cited in an informative manner (such references shall be listed in clause 2.2);
other reading material not explicitly referred to in the body of the ETSI deliverable (such publications have to be listed in an informative annex entitled "Bibliography" see clause 12.2);
not available in the English language.

If normative references cited in a deliverable are not publicly available during the drafting stage, the deliverable shall not be submitted to an approval procedure until the reference is publicly available. Or the text shall be made available.

Informative references mentioned in the body of the ETSI deliverable shall be listed in clause 2.2 (see informative references clause).

Informative references should be publicly available (but no check will be made).

The distinction between normative and informative references must be made by the wording of the passage of the deliverable which refers to it, not by the referenced document itself.

EXAMPLE: "the test method shall be as described in ITU-T Recommendation M.50",
ITU-T Recommendation M.50 is a normative reference.
"the test method is described in ITU-T Recommendation M.50",
ITU-T Recommendation M.50 is an informative reference.

The list of references under clause 2 shall be introduced by the following wording:

Text to be included into the deliverable:

2 References

References are either specific (identified by date of publication and/or edition number or version number) or non specific. For specific references, only the cited version applies. For non-specific references, the latest version of the referenced document (including any amendments) applies.

Referenced documents which are not found to be publicly available in the expected location might be found at http://docbox.etsi.org/Reference.

NOTE: While any hyperlinks included in this clause were valid at the time of publication ETSI cannot guarantee their long term validity.

2.1 Normative references

The following referenced documents are necessary for the application of the present document.

End of text to be included into the deliverable.

The above wording is also applicable to a part of a multipart document.

Use the EX style, enclose the number in square brackets and separate it from the title with a tab (you may use sequence fields for automatically numbering references, see clause A.4: "Sequence numbering") (see example).
EXAMPLE: |  |
 | [1] | ETSI EN 301 025-3: "Electromagnetic compatibility and Radio spectrum Matters (ERM); VHF radiotelephone equipment for general communications and associated equipment for Class "D" Digital Selective Calling (DSC); Part 3: Harmonized EN under article 3.3 (e) of the R&TTE Directive".
 | [2] | ETSI EN 300 163: "Television systems; NICAM 728: transmission of two-channel digital sound with terrestrial television systems B, G, H, I, K1 and L".

For online referenced documents, information sufficient to identify and locate the source shall be provided. Preferably, the primary source of the referenced document should be cited, in order to ensure traceability. Furthermore, the reference should, as far as possible, remain valid for the expected life of the document. The reference shall include the method of access to the referenced document and the full network address, with the same punctuation and use of upper case and lower case letters.

Text to be included into the deliverable.

2.2 Informative references

The following referenced documents are not necessary for the application of the present document but they assist the user with regard to a particular subject area.

End of text to be included into the deliverable.

 Use the EX style, add the letter "i" (for informative) before the number (which shall be in square brackets) and separate this from the title with a tab (you may use sequence fields for automatically numbering references, see clause A.4: "Sequence numbering") (see example).
EXAMPLE: |  |
 | [i.1] | ETSI TR 102 473: "Digital Video Broadcasting (DVB); IP Datacast over DVB-H: Use Cases and Services".
 | [i.2] | ETSI TR 102 469: "Digital Video Broadcasting (DVB); IP Datacast over DVB-H: Architecture".


References in a candidate Harmonized Standard

12.1 Void


Presentation of references in an ETSI Technical Report

12.2 Presentation of other reading material

This list within an annex shall be introduced by the following clause heading:

Annex <X> (informative):
Bibliography

The bibliography shall include the following:

 list of standards, books, articles, or other sources on a particular subject which are not referenced in the document.

The Bibliography shall not include the following:

 normative references (such references shall be listed in clause 2.1);
informative references (such references shall be listed in clause 2.2).
Use the Normal style or a bulleted style (e.g. B1+) and do not use numbered references. (If you want to refer to such a publication from the text use (see annex <X>or see bibliography) instead).

EXAMPLE 1: |
 | ITU-T Recommendation X.200: "Title".
 | Directive 1999/5/EC of the European Parliament and of the Council of 9 March 1999 on radio equipment and telecommunications terminal equipment and the mutual recognition of their conformity ("the R&TTE Directive").

EXAMPLE 2:
<Primary responsibility>. <Title>. <Edition>. <Year>, <Issue designation>, <Page location>.
(e.g. WEAVER, William. "Command performances". December 1985, vol. 42, n° 12, p. 126-133).
ISO/IEC 17875: "Title".


Presentation of informative references and other reading material

12.3 Normative references in Harmonized Standards

Normative references in Harmonized Standards shall be specific (identified by date of publication and/or edition number or version number). See clause 12.10.2.


Specific references

12.4 Non-specific references

Unlike ETSI, many other Standards bodies, (e.g. ISO, CEN, CENELEC) have a policy of regularly reviewing/maintaining their deliverables. Their procedures also involve the automatic withdrawal of the previous version. It therefore follows that any ETSI deliverable making specific references to such documents will need to be revised. It may, therefore, be appropriate that an ETSI deliverable contain non-specific references, provided that the following requirements can be fulfilled:

 it is accepted that it will be possible to use future versions of the document referred to for the purposes of the referring ETSI deliverable;
it is granted that the structure of the document referred to will not change for the specific areas which are used by the referring ETSI deliverable (e.g. the referred to document is controlled by the same Technical Body as the referring one).


Non-specific references

12.5 References to the ETSI deliverable as a whole in its own text
12.5.1 Single deliverable

The form "the present document ..." shall be used.


Non-specific references

12.5.2 Multi-part deliverable

The following formulation shall be used:

For a specific part:

- "EN 300 256-2 is ...".

For various specific parts:

- "EN 300 256-7 to EN 300 256-9 are....".

- "EN 300 256-5 and EN 300 256-8 are ...".

For all parts:

- "All parts of EN 300 256 ..."


References to the ETSI deliverable as a whole in its own text

12.6 References to elements of text

Use, for example, the following forms:

  • "in accordance with clause 3";
  • "according to clause 3.1";
  • "as specified in clause 3.1 b)";
  • "details as given in clause 3.1.1";
  • "see annex B";
  • "the requirements given in clause B.2";
  • "see the note in table 2";
  • ''see example 2 in clause 6.6.3";
  • "see note 3 in clause 6.6.1";
  • "see figure B.2 in clause 5.4".

If there is a need to refer to an unnumbered list item, the following formulation shall be used:

  • "as specified in clause 3.1, second list item".

Lower case letters are recommended (e.g. clause 1, annex A), however capital letters are also acceptable (e.g. Clause 1, Annex A). Usage shall be consistent throughout the document.

References shall be made in the forms indicated in clauses 12.4 to 12.7 and shall not be made to page numbers.


References to elements of text

12.7 References to tables and figures

Every table and figure included in the ETSI deliverable shall be referred to in the text, for example, using the following forms:

  • "given in table 2";
  • "(see table B.2)";
  • "shown in figure A.6";
  • "(see figure 3)".

Lower case letters are recommended (e.g. table 1, figure 2), however capital letters are also acceptable (e.g. Table 1, Figure 2). Usage should be consistent throughout the document.


References to tables and figures

12.8 References to specific or non-specific references

The following form shall be used consistently throughout the deliverable:

  • " … in accordance with ES 201 001 [n], clause 3, … ".


References to specific or unspecific references

12.9 Reference to 3GPP deliverables

All deliverables prepared by the 3rd Generation Partnership Project (3GPPTM) contain the following notice:

"The present document has been developed within the 3rd Generation Partnership Project (3GPPTM) and may be further elaborated for the purposes of 3GPPTM. The present document has not been subject to any approval process by the 3GPPTM Organizational Partners and shall not be implemented. This Specification is provided for future development work within 3GPPTM only. The Organizational Partners accept no liability for any use of this Specification. Specifications and reports for implementation of the 3GPPTM system should be obtained via the 3GPPTM Organizational Partners' Publications Offices."

For this reason, all references made to 3GPP documents made in draft deliverables will be changed by the ETSI Secretariat to a reference to the equivalent ETSI deliverable.

EXAMPLE: A reference to 3GPP TS 23.040 will be changed to a reference to ETSI TS 123 040.


Scope

12.10 Guidance for including references to documents of other organizations in ETSI deliverables
12.10.1 Scope

These rules for including references to documents of non-ETSI organizations in ETSI deliverables are intended to ensure that implementers and evaluators of deliverables standardized by ETSI, and other interested parties, have access to all materials needed to implement those deliverables. These rules apply to documents that are produced in accordance with the ETSI rules of procedures but also to any deliverables that are developed elsewhere that are sent to ETSI to be standardized.

Two categories of references are possible:

  1. "Normative references" are references to documents to which conformance is necessary to claim compliance to the ETSI deliverable containing the reference.

  2. "Informative references" are references to documents that may be useful in implementing an ETSI deliverable or add to the reader's understanding but which are not required for conformance to the ETSI deliverable.

These rules are pointed toward normative references because they are functionally a part of the ETSI deliverable itself. It is best practice to follow these principles for informative references as well, but more flexibility is permitted for informative references because these documents are not strictly necessary for the implementation of an ETSI deliverable.


Documents that may be referenced

12.10.2 Documents that may be referenced

In considering whether a normative reference to a document should be included in an ETSI deliverable, preference should be given to standards and specifications issued in the English language by recognized standards development organizations and to the directives of the European Union.

Normative referencing of documents under the possession of other organizations is allowed where the use of such normative references has been justified by the technical body in charge of development of the ETSI deliverable containing the reference. Where an objection to the use of a normative reference has been raised within Technical Body discussion, this shall be noted in the minutes or some other record that will be available to ETSI Members.

A normative reference to such a document is permissible only if the referenced document is publicly available, during the approval phases and at the time of publication of the ETSI deliverable. If public availability cannot be ensured after publication of the ETSI deliverable has occurred, the originating body of the document shall be requested to provide ETSI with the right to make available the text.

If normative references in an ETSI deliverable are not publicly available during the drafting stage, the deliverable shall not be submitted to an approval procedure until the reference is publicly available or the text shall be made available to be held by ETSI.


Public availability

12.10.3 Void


Intellectual property rights

12.10.4 Intellectual Property Rights (IPRs)

ETSI promotes a policy that any essential intellectual property rights (IPRs) embodied in normatively referenced documents be available for use in ETSI deliverables on licensing and disclosure terms that do not materially differ from the terms defined in the ETSI IPR Policy. This normative reference policy, however, does not imply any obligation on the Technical Body, ETSI members or Technical Body members to investigate or ensure the availability of any essential normatively referenced IPRs, under any specific licensing and disclosure terms, at the time a normative reference is provided, explicitly or implicitly, within an ETSI deliverable.


Stability and maintenance

12.10.5 Stability and maintenance

Normative references may be "specific" or "non-specific":

a. | A "specific" reference is a reference to the particular revision or version of the normatively referenced document. Specific references are favoured because they lead to permanence and stability in ETSI deliverables. Normative references generally should be limited to documents that are finally approved by the organizations responsible for issuing them.
b. | A "non-specific" reference is a reference to a deliverable of another organization that will apply to all future revisions and versions of the originally referenced document. Non-specific references require additional procedures to ensure that any revisions made necessary to the ETSI deliverable by virtue of revisions made to the normatively referenced materials are considered by the appropriate technical body in charge of the ETSI deliverable.

If a normative reference is non-specific, the technical body in charge of the ETSI deliverable should establish a process for gaining access to all future revisions and versions of the normatively referenced material. In addition, the technical body should establish a work plan for ensuring that any such new revisions and versions of the normatively referenced material do not require a substantive amendment to the ETSI deliverable referencing that document or, alternatively, for ensuring that any such needed amendments are made and approved appropriately. Any future versions incorporated by reference should meet with the requirements for public availability and Intellectual Property as set forth above.


Test suites

12.10.6 Test suites

If conformance with a specification that includes normative references requires the use of a test suite, the test suite for the normatively referenced part should also be made publicly available. Any such test suite should be usable by potential implementers on terms at least as favourable as those contained in the ETSI IPR Policy.


Terms and definitions in an ETSI deliverable

13 Terms and definitions in an ETSI deliverable

This is an optional element giving definitions necessary for the understanding of certain terms used in the ETSI deliverable. The following introductory wording, modified as appropriate, shall be used:

For the purposes of the present document, the [following] terms and definitions [given in ... and the following] apply:

  • A definition shall not take the form of, or contain, a requirement.
  • The form of a definition should be such that it can replace the term in context. Any additional information shall be given only in the form of examples or notes (see below).
  • The terms and definitions shall be presented in alphabetical order.

Examples of term's usage, and notes concerning entries, shall be presented as shown below.

  • EXAMPLE 1:

    communal site: location at which there is more than one fixed transmitter

NOTE: There are two types of communal site; one having separate equipment and antennas but housed in a common equipment room, and the other having an engineered system employing common antenna working where the isolation between equipments is determined by the filter system.
At all communal sites equipment installed on the site must meet the limits as specified in the relevant standards.
  • The term shall be in bold, and shall start with a lower case letter (unless it is always rendered with a leading capital) followed by a colon, one space, and the definition starting with a lower case letter and no ending full-stop.
  • Use the Normal style.
  • If there is several notes for the same definition, the notes shall be numbered. Otherwise it is not necessary.

EXAMPLE 2:

fast channel: channel with low latency but higher BER in comparison to the slow channel

EXAMPLE: In contrast to the slow channel, the fast channel is not interleaved.

requirement: provision that conveys criteria to be fulfilled


Symbols and abbreviations in an ETSI deliverable

14 Symbols and abbreviations in an ETSI deliverable

This is an optional element giving a list of the symbols and abbreviations necessary for the understanding of the ETSI deliverable. The following introductory wording, modified as appropriate, shall be used:

For the purposes of the present document, the [following] {<symbols>|<abbreviations>} [given in ... and the following] apply:

This list shall contain all technical abbreviations and their corresponding full terms which are used within the ETSI deliverable in alphabetical order.

This element, if it exists, shall be combined with the definitions in order to bring together terms and their definitions, symbols and abbreviations under an appropriate composite title, for example "Definitions, symbols and abbreviations".

Do not number the entries in the symbols and/or abbreviations clause.

  • Use the EW style (EX style for the last element in the list).
  • Separate the abbreviation from the full term with a tab.

EXAMPLE:

dB | decibel
DDI | Direct Dialling-In, or direct dialling-in


Verbal forms for the expression of provisions

14a Verbal forms for the expression of provisions

An ETSI deliverable does not in itself impose any obligation upon anyone to follow it. However, such an obligation may be imposed, for example, by legislation or by a contract. In order to be able to claim compliance with an ETSI deliverable, the user needs to be able to identify the requirements that are obligatory. The user also needs to be able to distinguish these requirements from other provisions where there is a certain freedom of choice.

Clear rules for the use of verbal forms (including modal auxiliaries) are therefore essential. In the first column of tables 3 to 6 the verbal form that shall be used to express each kind of provision is given. The equivalent expressions given in the second column shall be used only in exceptional cases when the form given in the first column cannot be used for linguistic reasons.

NOTE: Only singular forms are shown.

The verbal forms shown in table 3 shall be used to indicate requirements strictly to be followed in order to conform to the standard and from which no deviation is permitted.

Table 3: Requirement

Verbal form | Equivalent expressions for use in exceptional cases
shall | is to is required to it is required that has to only ... is permitted it is necessary
shall not | is not allowed [permitted] [acceptable] [permissible] is required to be not is required that ... be not is not to be
Do not use "must" as an alternative for "shall". (This will avoid any confusion between the requirements of a document and external statutory obligations.) Do not use "may not" instead "shall not" to express a prohibition. To express a direct instruction, for example referring to steps to be taken in a test method, use the imperative mood in English (e.g. "switch on the recorder"). "exceptional cases" means where the ETSI Drafting Rules, if applied, would change the meaning of the sentence or make it difficult to understand.

The verbal forms shown in table 4 shall be used to indicate that among several possibilities one is recommended as particularly suitable, without mentioning or excluding others, or that a certain course of action is preferred but not necessarily required, or that (in the negative form) a certain possibility or course of action is deprecated but not prohibited.

Table 4: Recommendation

Verbal form | Equivalent expressions for use in exceptional cases
should | it is recommended that ought to
should not | it is not recommended that ought not to
"exceptional cases" means where the ETSI Drafting Rules, if applied, would change the meaning of the sentence or make it difficult to understand.

The verbal forms shown in table 5 are used to indicate a course of action permissible within the limits of the ETSI deliverable.

Table 5: Permission

Verbal form | Equivalent expressions for use in exceptional cases
may | is permitted is allowed is permissible
need not | it is not required that no ... is required
Do not use "possible" or "impossible" in this context. Do not use "can" instead of "may" in this context. "exceptional cases" means where the ETSI Drafting Rules, if applied, would change the meaning of the sentence or make it difficult to understand. NOTE: "May" signifies permission expressed by the standard, whereas "can" refers to the ability of a user of the standard or to a possibility open to him.

The verbal forms shown in table 6 are used for statements of possibility and capability, whether material, physical or causal.

Table 6: Possibility and capability

Verbal form | Equivalent expressions for use in exceptional cases
can | be able to there is a possibility of it is possible to
cannot | be unable to there is no possibility of it is not possible to
Do not use " may" instead of "can" in this context. "exceptional cases" means where the ETSI Drafting Rules, if applied, would change the meaning of the sentence or make it difficult to understand. NOTE: "May" signifies permission expressed by the standard, whereas "can" refers to the ability of a user of the standard or to a possibility open to him.

The verbal forms shown in table 6a shall be used to indicate behaviour of equipment or sub-systems outside the scope of the deliverable in which they appear. For example, in a deliverable specifying the requirements of terminal equipment, these forms shall be used to describe the expected behaviour of the network or network simulator to which the terminal is connected.

Table 6a: Inevitability

Verbal form Equivalent expressions
will
will not
Distinguish from "shall" / "shall not". Use to express behaviour of equipment or systems outside the scope of the deliverable being drafted, where description of such behaviour is essential to the correct understanding of the requirements pertaining to equipment within the scope of the current deliverable.

EXAMPLE: Extract from deliverable specifying behaviour of terminal equipment: "… On expiry of timer T3, the terminal shall send a TIMEOUT message to the network and start timer T4. The network will respond with a TIMOUT-ACKNOWLEDGE message. On receipt of a TIMEOUT‑ACKNOWLEDGE message, the terminal shall stop timer T4 …"; thus is distinguished the strong future ("the terminal shall") used for requirements and the normal future ("the network will") used to indicate expected events.
The verbal forms shown in table 6b shall be used to indicate statements of fact.

Table 6b: Fact

Verbal form | Equivalent expressions
is | Any verb in the indicative mood, present tense.
is not
Distinguish from "shall" / "shall not". Do not use present indicative of verbs for expressing requirements.


Requirements

15 Requirements and test methods
15.1 Requirements

This element is optional. If present, it shall contain:

a) | all characteristics relevant to the aspect(s) of the product(s), process(es) or service(s) covered by the ETSI deliverable, either explicitly or by reference;
b) | the required limiting values of quantifiable characteristics.

A clear distinction shall be made between requirements, statements and recommendations (see also clause 14a).

Contractual requirements concerning claims, guarantees, covering of expenses, etc. shall not be included.

ETSI deliverables listing characteristics for which suppliers are required to state values that are not specified by the ETSI deliverable itself shall specify how such values are to be measured and stated.

For endorsement of documents from other standards organizations, see annex C.


Test methods

15.2 Test methods

This optional element gives all the instructions concerning the procedure for determining the values of characteristics, or for checking conformity to stated requirements, and for ensuring the reproducibility of the results. If appropriate, tests shall be identified to indicate whether they are type tests, routine tests, sampling tests and so on.

Instructions relating to test methods may be subdivided in the following order (where appropriate):

a) principle;

b) apparatus;

c) preparation and preservation of test samples and test pieces;

d) procedure;

e) test report.

Test methods may be presented as separate clauses, or be incorporated in requirements, or be presented as annexes (see clause 16.1) or as separate parts (see clause 5.2.1). A test method shall be prepared as a separate ETSI deliverable if it is likely to be referred to in a number of other ETSI deliverables.

The need for specification of test methods shall be evaluated on a case by case basis, in accordance with TCR TR 006 [i.2].

A test specification enables verification that products designed to a standard conform to its requirements. When writing a TS, ES or EN, you should consider the need for an accompanying test specification.

Every requirement of an ETSI deliverable specifying a product (equipment, system or service) needs to be testable, and such requirements need to be clearly distinguishable from statements of fact or of supposition.

EXAMPLE: Comparing the two sentences below:

"On receiving a START CALL message, the terminal shall respond by sending an ACKNOWLEDGE message within a delay of t1."

"On receiving a START CALL primitive, the layer 3 protocol of the terminal shall move to state CALL ACTIVATED and shall start timer t2."

It is clear that conformance to the first requirement can be verified by external stimulus and observation, whereas the second puts demands on a conceptual model which cannot be explicitly tested. Whilst requirements of the latter sort are useful - even essential - for describing operational details, the essential behavioural characteristics (normative provisions) are given by requirements of the type of the former, and only these are verifiable.


Annex in an ETSI deliverable - General

16 Annex in an ETSI deliverable
16.1 Usage

For the description of normative and informative annexes, see clauses 16.2 and 16.3.

Each annex shall start on a new page.

Each annex shall be designated by a heading comprising the word "Annex" followed by a capital letter designating its serial order, beginning with "A", e.g. "Annex A" (see also clause 5.2.1a). The annex heading shall be followed by the indication "(normative):" or "(informative):", and by the title on the next line.

EXAMPLE 1: Annex A (normative):
Title of annex A

NOTE: Exceptions to this rule are for the deliverable types EG, TR and SR which are entirely informative. Thus the addition of "(normative):" or "(informative):" after the annex identifier is superfluous and shall not be provided.

EXAMPLE 2: Annex A:
Title of annex A

Numbers given to the clauses, tables, figures and mathematical formulae of an annex shall be preceded by the letter designating that annex followed by a full-stop (e.g. figure B.1, table C.4). The numbering shall start afresh with each annex. A single annex shall be designated "Annex A".

Clauses in annex A shall be designated "A.1", "A.2", "A.3", etc. (see also clause 5.2.1a).

For endorsement of documents from other standards organizations, see annex C.

  • Use the Heading 8 style (for EG, TR and SR use the Heading 9 style) for the annex heading. Insert a line break ("shift" + ¿ "enter") between the colon and the title.
  • For all annex clause headings use the appropriate Heading styles, starting from Heading 1, e.g. for clause A.1 use Heading 1, for clause A.1.1 use Heading 2.


Annex in an ETSI deliverable - Normative annexes

16.2 Normative annexes

For reasons of convenience it may be decided to place some part of the normative text in an annex.

Normative annexes contain provisions to which it is necessary to conform in order to be able to claim compliance with the ETSI deliverable. Their presence is optional and their status (except for EGs, TRs and SRs, see note in clause 16.1) shall be indicated in the heading of the annex.


Annex in an ETSI deliverable - Informative annexes

16.3 Informative annexes

For reasons of convenience it may be decided to place some part of the informative text in an annex.

Informative annexes give additional information intended to assist the understanding or use of the ETSI deliverable and shall not contain provisions to which it is necessary to conform in order to be able to claim compliance with the ETSI deliverable. Their presence is optional and their status (except for EGs, TRs and SRs, see note in clause 16.1) shall be indicated in the heading of the annex.

The following annexes are optional and if present, will be displayed in the following order before the history box (see clause 19):
• Bibliography (see clause 17),
• Index (see clause 18),
• Change history or Change request (history) (see clause 18a).

NOTE: Each of these elements shall start on a new page.


Bibliography in an ETSI deliverable

17 Bibliography in an ETSI deliverable

Bibliography"shall be the last annex.

The annex entitled "Bibliography" identifies informative references and other reading material. Those publications might or might not be publicly available (no check is made), but are definitely not mentioned in the document itself.

  • For the "Bibliography" annex use Heading 8 style.

    • NOTE: For EGs, TRs and SRs, the style heading 9 shall be used.

  • For the listed material use the Normal style or bulleted lists (e.g. B1+).


Index in an ETSI deliverable

18 Index in an ETSI deliverable

The title shall be "Index".

 Format the index in a section having two columns separated by 0,5 cm using the field {INDEX \e "®" \c "2"}.
Use the Heading 1 style for the title.


Index in an ETSI deliverable

18a Change history/Change request (history)

A change history / Change request (history) annex is optional, if present it shall be presented as a table.


History in an ETSI deliverable

19 History in an ETSI deliverable

A history box shall be provided by the ETSI Secretariat as the final unnumbered element in an ETSI deliverable and shows the major milestones in the life of a document.

If it is desired to keep a detailed record of the document history (other than the major milestones) it is recommended that this is done by inserting a separate, informative annex.

  • Use Heading 1 style for the title.


Notes and examples integrated in the text

20 Notes and examples
20.1 Notes and examples integrated in the text

Notes and examples should preferably be placed at the end of the clause, or after the paragraph, to which they refer.

Notes and examples integrated in the text shall only be used for giving additional information intended to assist the understanding or use of the ETSI deliverable. They shall not contain any information considered indispensable for the use of the deliverable.

A single note in a clause shall be preceded by "NOTE:", placed at the beginning of the first line of the text of the note. When several notes occur within the same element (e.g. clause), they shall be designated "NOTE 1:", "NOTE 2:", "NOTE 3:", etc. (see also clause 5.2.1a).

The word NOTE shall appear in upper case.

  • Use the NO style.
  • Separate NOTE: from the text of the note with a tab.

EXAMPLE 1:

NOTE: Text formatted with the NO style will be formatted with a space after the paragraph.

END of EXAMPLE 1

A single example in a clause shall be preceded by "EXAMPLE:", placed at the beginning of the first line of the text of the example. When several examples occur within the same element (e.g. clause), they shall be designated "EXAMPLE 1:", "EXAMPLE 2:", "EXAMPLE 3:", etc. (see also clause 5.2.1a).

When there is a danger that it may not be clear where the example ends and the normal text continues, then the end of the example may be designated by "END of EXAMPLE".

The word EXAMPLE shall appear in upper case.

  • Use the EX style.
  • Separate EXAMPLE: from the text of the example with a tab.

EXAMPLE 2:

EXAMPLE: Example text.

END of EXAMPLE 2


Footnotes to the text

20.2 Footnotes to the text

Footnotes shall not be used in ETSI deliverables. If necessary notes integrated to the text shall be used.


Notes to figures

20.3. Notes to figures and notes to tables
20.3.1 Notes to figures

Notes to figures shall be treated independently from notes integrated in the text (see clause 20.1) and for this reason may contain requirements. They shall be located above the title of the relevant figure. A single note in a figure shall be preceded by "NOTE:". When several notes occur in the same figure, they shall be designated "NOTE 1:", "NOTE 2:", "NOTE 3:", etc. (see also clause 5.2.1a). A separate numbering sequence shall be used for each figure.

  • Write notes to a figure using the word processor rather than embedding them in the figure itself.
  • Use the NF style.
  • Separate NOTE: from the text of the note with a tab.


Notes to tables

20.3.2 Notes to tables

Notes to tables shall be treated independently from notes integrated in the text (see clause 20.1) and for this reason may contain requirements. They shall be located within the frame of the relevant table. A single note in a table shall be preceded by "NOTE:". When several notes occur in the same table, they shall be designated "NOTE 1:", "NOTE 2:", "NOTE 3:", etc. (see also clause 5.2.1a). A separate numbering sequence shall be used for each table.

  • Use the TAN style.
  • Separate NOTE: from the text of the note with a "Ctrl" + "®" (tab).
  • Include notes to a table within its borders in one cell, at the bottom.
  • Merge all cells to one, as in the following example:

EXAMPLE:

Column 1 cell Column 2 cell (see note 2) Column 3 cell Column 4 cell (see note 1)
NOTE 1: This cell is a merged cell.
NOTE 2: This cell is also a merged cell.


Figures - Usage

21 Figures
21.1 Usage

Figures should be used wherever appropriate to present information in an easily comprehensible form. Each figure shall be referred to explicitly within the text and, therefore, be numbered.


Figures - Format

21.2 Format

Figures shall be prepared in accordance to clauses A.5 and/or B.1.

  • Use the FL style on the paragraph which contains the figure itself.
  • Maximum width for figures is 17 cm and maximum height is 22 cm.


Figures - Numbering

21.3 Numbering

Figures may be numbered sequentially throughout the document without regard to the clause numbering, e.g. first figure is figure 1 and the twentieth figure (in, say clause 7) is figure 20.

Figures may also be numbered taking account of clause numbering.

EXAMPLE 1: | First figure in clause 5 is figure 5.1, second figure in clause 5.1.1 is figure 5.2, third figure in clause 5.2.3 is figure 5.3.
EXAMPLE 2: | First figure in clause 7 is figure 7.1, fifth figure in clause 7 is figure 7.5.
EXAMPLE 3: | First figure in clause 7.3.2 is figure 7.3.2.1, fifth figure in clause 7.3.2 is figure 7.3.2.5.

One level of subdivision only is permitted (e.g. figure 1 may be subdivided as 1 a), 1 b), 1 c), etc.). See also clause 5.2.1a. For the numbering of figures in annexes, see clause 16.1.

 Should you wish to number figures automatically, "Sequence numbering" (see clause A.4) is highly recommended. Also see clause 5.2.3.


Figures - Layout of title

21.4 Layout of title

The figure title shall be below the figure. An explicit figure title is optional. See the following examples:

EXAMPLE 1:

Figure 1: Details of apparatus

EXAMPLE 2:

Figure 1

  • Use the TF style.
  • If applicable, the figure number is followed by a colon, a space and the figure title.


Tables - Usage

22 Tables
22.1 Usage

Tables should be used wherever appropriate to present information in an easily comprehensible form. Each table shall be referred to explicitly within the text and therefore be numbered.

 Centre tables horizontally.
The "space between columns" is 0,1 pt or 0,05 cm.
Maximum width for tables in portrait orientation: 17 cm and for landscape orientation: 22 cm
Set table columns widths in centimetres (not inches).
Use borders to separate the rows and columns of tables, as appropriate; the precise format will depend on the structure of each table, but be consistent throughout a deliverable (or series of related deliverables). Borders should be ¾ pt single line.
Each table shall be followed by an empty "Normal" style paragraph (¿ "Enter" key).


Tables - Format

22.2 Format

The following styles should be used in table cells.

 Table Headings TAH
Text Left aligned TAL
Text Centred TAC
Text Right aligned TAR
Table Note TAN

List in tables Level 1 TB1
List in tables Level 2 TB2


Continuation of tables

22.3 Continuation of tables

The column headings shall be repeated on all pages after the first.

  • Use the table headings tool (Table, Headings Rows Repeat).


Tables - Numbering

22.4 Numbering

Tables may be numbered sequentially throughout the document without regard to the clause numbering, e.g. the first table is table 1 and the twentieth table (in, say clause 7) is table 20.

Tables may also be numbered taking account of clause numbering.

EXAMPLE 1: | First table in clause 5 is table 5.1, second table in clause 5.1.1 is table 5.2, third table in clause 5.2.3 is table 5.3.
EXAMPLE 2: | First table in clause 7 is table 7.1, fifth table in clause 7 is table 7.5.
EXAMPLE 3: | First table in clause 7.3.2 is table 7.3.2.1, fifth table in clause 7.3.2 is table 7.3.2.5.

One level of subdivision only is permitted (e.g. table 1 may be subdivided as 1 a), 1 b), 1 c), etc.). See also clause 5.2.1a. For the numbering of tables in annexes, see clause 16.1.

 Should you wish to number tables automatically, "Sequence numbering" (see clause A.4) is highly recommended. Also see clause 5.2.3.


Tables - Layout of title

22.5 Layout of title

The title shall be above the table. An explicit table title is optional. See the following examples:

EXAMPLE 1:

Table 1: Electrical properties

EXAMPLE 2:

Table 1

  • Use the TH style.
  • If applicable, the table number is followed by a colon, a space and the table title.


Tables - Headings

22.6 Headings

The first word in the heading of each column shall begin with a capital letter. The units used in a given column shall generally be indicated within the column heading.

EXAMPLE:

Type | Linear density (kg/m) | Inside diameter (mm) | Outside diameter (mm)


Verbal forms for the expression of provisions

23 (Void)


Use of capital letters

24 Use of capital letters

Unnecessary use of capital letters should be avoided.

EXAMPLE: "user" is preferred to "User".


Different items concerning text

24a Different items concerning text

Use bold to emphasize text (the underline attribute causes confusion when revision marks are used).

Use italic for citations, linguistic expressions or when a word/text/expression is extracted from a specific context.

Use non-breaking spaces (°) or non-breaking hyphens (_) in order to avoid unexpected wrap around between two words and/or numbers (e.g. 50°cm, 1°000, clause°6 etc.). These characters appear as normal spaces or hyphens (-) when printed out.

Use "straight" quotation marks ("...") not “curly” or “smart quotes”.

It is not recommended to use underlined text (to avoid confusion with revision marks).

Do not put more than one space after a full stop.

Do not precede comma (,), semicolon (;), colon (:), full stop (.), question mark (?) or exclamation mark (!) by spaces.

Do not use spaces in place of tabs when indentation/alignment is required; this can cause text to be misaligned.


Pagination

25 Pagination

Unnecessary forced pagination, (i.e. use of hard page breaks) should be avoided.

 Use Format | Paragraph | Text Flow | Keep Lines Together and Keep with Next attributes instead of "hard" page breaks.


Use of trade names

26 Use of trade names (trade marks)

Proprietary trade names (e.g. trade marks) for a particular good or service should as far as possible be avoided, even if they are in common use. Instead a correct designation or description of a product should be given.

If, in exceptional circumstances, trade names cannot be avoided, their nature shall be indicated, e.g. by the symbol® or TM for a registered trade mark (see example 1).

EXAMPLE 1: Instead of "Teflon®", write "polytetrafluoroethylene (PTFE)".

If it is known that only one product is currently available that is suitable for the successful application of the standard, the trade name of the product may be given in the text of the standard but shall be associated with a note as shown in example 2.

EXAMPLE 2: |
NOTE 1: | "… [trade name of product] … is the trade name of a product supplied by … [supplier] …. This information is given for the convenience of users of the present document and does not constitute an endorsement by ETSI of the product named. Equivalent products may be used if they can be shown to lead to the same results."

If it is considered to be essential to give an example (or examples) of commercially available products suitable for successful application of the standard because the product characteristics are difficult to describe in detail, trade names may be given in a note as shown in example 3.

EXAMPLE 3: |
NOTE 2: | " … [trade name(s) of product(s)] … is (are) an example(s) of a suitable product(s) available commercially. This information is given for the convenience of users of the present document and does not constitute an endorsement by ETSI of this (these) product(s)."


Representation of numbers and numerical values

27 Representation of numbers and numerical values

The decimal sign shall be a comma. The thousand separator shall be a space.

NOTE 1: In the text below, ° represents the non-breaking space character.

If a value less than 1 is written in decimal form, the decimal sign shall be preceded by a zero.

EXAMPLE 1: 0,001.

Each group of three digits reading to the left of a decimal sign shall be separated by a space from preceding digits or following digits respectively, except for four-digit numbers designating years.

EXAMPLE 2: 23°456 2°345 2,345 2,3456 2,34567 but the year 1997.

For clarity, the symbol ´ or a lower case x (rather than a point or any other symbol) shall be used to indicate multiplication of numbers and numerical values.

EXAMPLE 3: Write 1,8°×°10-3 (not 1,8 * 10-3 or 1,8 Ÿ 10-3 or 1,8 .10-3).

NOTE 2:

The exception is vector values because it makes a difference whether multiplying with a "=" (scalar value) or with a "´" (vector value).

To express numbers of items (as opposed to numerical values of physical quantities), the numerals one to nine shall be spelt out in full.

EXAMPLE 4: "Carry out the test on five tubes, each 5 m long."

EXAMPLE 5: "Select a further 15 tubes for the pressure test."

Preserve document identities as in the original titles.

EXAMPLE 6: ISO/IEC°10531-1 (not ISO/IEC 10°531-1).

EXAMPLE 7: ES°201°150.

Put a non-breaking space between a number and its unit - including the percent sign (%) - even if the unit is not abbreviated:

EXAMPLE 8: 2ºpages 4ºseconds 15º%.

Write a number preceded by a unary operator (sign) without an intervening space, except for ?, ?, >,

EXAMPLE 9: … a level of -3°dB … but > 3 dB

Put a non-breaking space both before and after binary operators (+, -, ×, etc.):

EXAMPLE 10: a°+°b°=°c

  • Use non-breaking spaces ("Ctrl" + "Shift" + space) for the thousand separator, before and after binary operators and preceding units.
  • Use a non-breaking hyphen ("Ctrl" + 8) for the minus sign.


Quantities, units, symbols and signs

28 Quantities, untis, symbols and signs

The units in which any values are expressed shall be indicated.


Tables - Numbering

28.1 Indication of dimensions and tolerances

Dimensions and tolerances shall be indicated in an unambiguous manner.

NOTE 1: I n the text below, ° represents the non-breaking space character.
EXAMPLE 1: 80 mm°°25 mm°°50 mm (not 80  25  50 mm).
EXAMPLE 2: 80 µF°°2 µF or (80  2) µF.
EXAMPLE 3: 16 kbit/s to 64 kbit/s (not 16 to 64 kbit/s).
EXAMPLE 4: 0 °C to 10 °C (not 0 to 10 °C).
EXAMPLE 4a: X = [1..8].

In order to avoid misunderstanding, tolerances on percentages shall be expressed in a mathematically correct form.

EXAMPLE 5: Write "from 63°% to 67°%" to express a range.
EXAMPLE 6: Write "(65°°2)°%" to express a centre value with tolerance.

The form "65°°2°%" shall not be used.

NOTE 2: For "scientific units" (e.g. "s" for second(s)), please refer to the "Use of English guide" available from editHelp!.


Mathematical formulae - Types of equations

29 Mathematical formulae
29.1 Type of equations

Equations between quantities are preferred to equations between numerical values. Equations shall be expressed in mathematically correct form, the variables being represented by letter symbols the meanings of which are explained in connection with the equations, unless they appear in a "Symbols and abbreviations" clause (see clause 14). Descriptive terms, acronyms or names of quantities shall not be arranged in the form of an equation.

EXAMPLE:

where: | xj are samples of time errors data;
 | N is the total number of samples;
 | t is the time error sampling interval;
 | n is the number of sampling intervals, with n = 1, 2, ..., integer part (N/3).


Tree and Tabular Combined Notation (TTCN)

29.2 Presentation

It is recommended to use Microsoft® Equation Editor.

  • Use the EQ style.
  • Insert one tab before the equation to centre it.

The equation editor sizes and styles should be respected as shown in the following examples:

In order to apply the following required settings, please download the equation editor registry file (available from editHelp!.


Mathematical formulae - Numbering

29.3 Numbering

If it is necessary to number some or all of the formulae in an ETSI deliverable in order to facilitate cross-reference, Arabic numbers in parentheses shall be used, beginning with 1:

EXAMPLE 1:

x2 + y2 < z2 (1)

Equations may be numbered sequentially throughout the document without regard to the clause numbering, e.g. first equation is equation 1 and the twentieth equation (in, say clause 7) is equation 20.

Equations may also be numbered taking account of clause numbering.

EXAMPLE 2: | First equation in clause 5 is equation 5.1, second equation in clause 5.1.1 is equation 5.2, third equation in clause 5.2.3 is equation 5.3.
EXAMPLE 3: | First equation in clause 7 is equation 7.1, fifth equation in clause 7 is equation 7.5.
EXAMPLE 4: | First equation in clause 7.3.2 is equation 7.3.2.1, fifth equation in clause 7.3.2 is equation 7.3.2.5.

See also clause 5.2.1a. For the numbering of equations in annexes see clause 16.

 Should you wish to number equations automatically, "Sequence numbering" (see clause A.4) is highly recommended. Also see clause 5.2.3.
Insert a tab between the equation and the number to right-align the number.


Indication of dimensions and tolerances

30 Void


Presentation of computer language and other code

31 Presentation of computer language and other code

Computer code (e.g. ASN.1, GDMO, C, C++, etc.) may be included in an ETSI deliverable but should be clearly marked as such.

  • Use the PL style.

Large volumes of program code, source code or formal description language shall be placed in an electronic attachment accompanying the ETSI deliverable. See clause B.2 for further details.


Use of trade names

32 Use of photographs

Photographs shall be used only in accordance with the relevant provisions of the ETSI IPR Policy and the ETSI Guide on IPRs.

If the photograph shows a person and if there are doubts about the respect of the rights of personality of that person, a written confirmation that those rights have not been invaded and have been fully respected shall also be obtained from the author of the photograph.


The ETSI styles

Annex A Notes and examples
A.1 The ETSI styles

Use table A.1 when determining which style to use for various elements of the deliverable. Do not alter existing styles or formats pre-set in the ETSI styles, do not add new styles to the ETSI template and do not delete ETSI styles (see style FP in table A.1).

Table A.1

Use this style | For this type of element
Heading styles | For different headings
Heading 1 | Clause
Heading 2 to 5 | Subdivision level 2 to 5
Heading 8 | Annex title
Heading 9 | Annex title for TRs and SRs only
H6 | Subdivision level 6 (not reflected in the table of contents)
Example styles | For examples and abbreviations/symbols lists
EX | Reference, Example ®
EW | Symbol, Abbreviation, Example continuation in text ®
Note style |
NO | Note integrated in the text ®
Figure styles | For formatting figures
TF | Figure title
FL | Figure layout
NF | Figure note ®
Table styles | For formatting tables
TH | Table title
TAH | Heading within table or column heading
TAC | Centred text within tables
TAL | Left aligned text within tables
TAR | Right aligned text within tables
TAN | Note in table ®
TB1 | List in table Level 1
TB2 | List in table Level 2
List styles (indents) |
B1 to B5 | Indent 1 to 5
B1+ | Bulleted indent 1 (round bullets)
B2+ | Bulleted indent 2 (dashes)
B3+ | Bulleted indent 3 (square bullets)
BN | Bulleted (numbers) indent 1
BL | Bulleted (letters) indent 1
General styles | For different items
Normal | Standard paragraph, Definition
TT | Contents list title
PL | Programming language
EQ | Equation
Header | Header (portrait and landscape pages)
Style which can be user-defined | For formatting defined by the user that will not be altered by the ETSI processing macros
FP | Free Paragraph
® use "tab" between "item/number" and "text". EXAMPLE: The "tab" is preceding this example text. NOTE: Other styles exist in the template, but are for use by the Secretariat only.


Page numbering, page headers and footers

A.2 Page numbering, page headers and footers

The skeleton document supplies fields for automatic page numbering and the identification of the deliverable in the page header. Do not add anything to or delete anything from the headers and footers.

  • Use the HEADER style on all page headers (sections) except for the title page (section).


Configuration of the Windows environment

A.3 Configuration of your PC computer

Set your PC environment to use the English (International) conventions (via Control Panel, International).

  • Use centimetres as the preferred unit of measurement.
  • Do not select "Change 'Straight Quotes' to 'Smart Quotes' " in the AutoCorrect options.
  • Set Default Tab Stops to 0,5 cm.
  • The remaining configurable elements of your PC and of Word are at your discretion.


Sequence numbering and bookmarking

A.4 Sequence numbering and bookmarking

Sequence numbering is highly recommended to automatically number sets of items within a deliverable, especially if the document is long and/or contains numerous references, tables, figures, equations, etc. It avoids renumbering the whole sets when inserting new items.

Sequence numbers may also be bookmarked, in order to facilitate cross-referencing throughout the text: it avoids renumbering cross-references and guarantees their accuracy.

Do not use cross-referencing option, since it implies the use of automatic heading or caption numbering (see clause 5.2.3).

Use the following sequence identifiers (Insert Field Numbering Seq and type in the relevant sequence identifier):

Table A.2: Sequence numberings

Sequence | Bookmark name | Description
seq equ | equ_xx | for equations (note 1)
seq fig | fig_xx | for figures (note 1)
seq ref | ref_xx | for references
seq tab | tab_xx | for tables (note 1)
NOTE 1: Reset the sequence numbering to one for the first item of each annex of an ETSI deliverable by using the switch \r1 e.g. { seq fig \r1 }). NOTE 2: "xx" represents the identifier for the particular object concerned, e.g. "fig_ProcessControl" or "ref_en300466". Do not use bookmarks of the form "fig_fig1". You can use underscores as separators in sequence identifiers if necessary.

Thus the title of a table will read:

Table { seq tab }: Table title

Bookmark each entry in a sequence (select it and use Insert/Bookmark Add), using a bookmark name of the form shown in table 1. You can then refer to the table, figure, reference, etc. from the text by inserting a sequence field citing the same sequence identifier and the particular bookmark required. For example, table 1 has been bookmarked "tab_Seq_Num". Thus a reference to this table from the text reads:

… see table { seq tab tab_Seq_Num } …

Remember to refresh the fields in order to view the correct numbers by using the "Update fields" command (F9).


Supported file formats

A.5 Supported file formats

The following document formats are currently accepted by the ETSI Secretariat:

  • Microsoft® Word 2007
  • Microsoft® Word 2003
  • Microsoft® Word 2000
  • Microsoft® Word XP
NOTE 1: Versions prior to this are strongly discouraged.

The following file formats for embedding into a document are currently accepted by the ETSI Secretariat:

  • Microsoft® Visio®2000 and 2007
NOTE 2: | Regarding the use of stencils or templates, it is recommended to use those supplied with the standard version. If additional ones are used, they should be provided to the Secretariat, together with the electronic version of the deliverable.
NOTE 3: | Microsoft® Visio® shall not be used for SDL production (see annex B).
  • Microsoft® Office® products

The information in this clause was valid at publication of the present document. Please consult http://portal.etsi.org/edithelp/drafting_tools.asp for subsequent updates.


SDL diagrams

Annex B Text containing SDL, program code, ICS and TTCN
B.1 SDL and MSC diagrams

There are three ways to include SDL diagrams (Specification and Description Language), MSC diagrams (Message Sequence Charts) or HMSC diagrams (High level MSC) as part of an ETSI deliverable.

  • One is to embed SDL, MSC or HMSC diagrams in Word documents by selecting the diagram contents in the SDL/MSC tool and copy/paste into Word. Further editing as Word picture gives poor results and should be avoided.

  • A second way is to include embedded postscript files produced by an SDL/MSC tool into the Word document.

In both these cases, provide SDL, MSC or HMSC diagrams in SDT binary files or as CIF files when not using SDT. Do not include SDL headers or footers.

  • A third way is to provide the SDL model or MSC and HMSC diagrams as a separate file. This is recommended for large SDL models or large collection of MSC diagrams. In this case, provide CIF files, postscript or PDF files, and also if using SDT include the SDT binary files. If the SDL model uses ASN.1 data, include the ASN.1 data files, to be published with the CIF files.

NOTE: Microsoft® Visio® shall not be used for SDL production.


Program code

B.2 Program code

Large volumes of program code, source code or formal description language shall be placed in an electronic attachment accompanying the ETSI deliverable.

Machine readable code contained in an electronic attachment will be considered as the definitive text, in the case of discrepancy with text reproducing the same code in the ETSI deliverable.

Text to be used when files are attached to the document (if nothing already mentions it in the document):

Add the following text block to the Foreword:

The <type> {diagrams|figures|files|<others>} are contained in archive <shortfilename> which accompanies the present document.

EXAMPLE: The SDL diagrams for the V 5.2 system are contained in archive en_30034701v010101p0.zip which accompanies the present document.

XML code may, in addition, be stored at the URI referenced in the XML code. XML code which uses the ETSI root URI http://uri.etsi.org/xxxxx/ (where xxxxx is the five digit number obtained by removing the first digit of the ETSI document number, and any part or sub-part numbers) may, upon request, be stored by the ETSI Secretariat at the appropriate location in the http://uri.etsi.org space.


Implementation Conformance Statement (ICS) proforma tables

B.3 Implementation Conformance Statement (ICS) proforma tables

Use the guidance and the ICS proforma templates contained in EG 201 058 (available at editHelp!).


Program code

B.4 Testing and Test Control Notation (formely Tree and Tabular Combined Notation (TTCN))

Provide TTCN as a separate file.

For test suite speficied in TTCN version 2 (TTCN-2):

Provide both Graphical Rendition (GR) and Machine Processable (MP) files.

The following text should be used for ATSs using TTCN-2. The subdivision is recommended.

This ATS has been produced using the Tree and Tabular Combined Notation (TTCN) according to ISO/IEC 9646-3 [<x>].

The ATS was developed on a separate TTCN software tool and, therefore, the TTCN tables are not completely referenced in the table of contents. The ATS itself contains a test suite overview part which provides additional information and references.

For test suite specified in TTCN version 3 (TTCN-3) Tabular Format:

Provide both Graphical Rendition (GR) and Machine Processable (MP) files.

The following text should be used for ATSs using TTCN-3 Tabular Format. The subdivision is recommended.

This ATS has been produced using the Testing and Test Control Notation (TTCN) according to ES 201 873-2 [<x>].

The ATS was developed on a separate TTCN software tool and therefore the TTCN tables are not completely referenced in the table of contents. The ATS itself contains a test suite overview part which provides additional information and references.

For test suites specified in TTCN version 3 (TTNC-3) Core Language:

Provide only the machine processable (MP) file.

The following text should be used for ATSs using TTCN-3 Core Language. The subdivision is recommended.

This ATS has been produced using the Testing and Test Control Notation (TTCN) according to ES 201 873-2 [<x>].

<x1> The TTCN Graphical form (TTCN.GR)

The TTCN.GR representation of this ATS is contained in a Portable Document Format™ file (<any_name>.pdf contained in archive <filename>.zip) which accompanies the present document.

<x2> The TTCN Machine Processable form (TTCN.MP)

The TTCN.MP representation corresponding to this ATS is contained in an ASCII file (<any_name>.MP contained in archive <filename>.zip) which accompanies the present document.

Where an ETSI Abstract Test Suite (in TTCN) is published in both .GR and .MP format these two forms shall be considered equivalent. In the event that there appears to be syntactical or semantic differences between the two then the problem shall be resolved and the erroneous format (whichever it is) shall be corrected.


Endorsement of documents from other standards organizations - General

Annex C Endorsement of documents from other standards organizations
C.1 General

In the case that an ETSI deliverable would become almost identical to (i.e. with or without modifications use the entirety of) a document from another standards organization, the Technical Body may decide to prepare an ETSI deliverable defining only the differences, if any, between that document (commonly called "endorsed document") and the ETSI deliverable.

Such an ETSI deliverable, commonly called "endorsement", shall be drafted in accordance with the present document, in addition to clauses C.2 and C.3.

The preferred method of endorsement is defined in clause C.2.

In exceptional circumstances and in justified cases only, the methods defined in clause C.3 may be used.


Endorsement of documents from other standards organizations - Title

C.2 Title, requirements and annexes
C.2.1 Title
C2.1.1 Without modifications

If the endorsed document is referred to without modifications, the title of the ETSI deliverable should be as close as possible to the title of the endorsed document (see example), while still complying with the provisions of clause 6.

EXAMPLE:

Endorsement of ITU-T Recommendation Q.1215 (1993): "Physical plane for intelligent network CS1", gives the following ETSI deliverable title:

Intelligent Network (IN);
Physical plane for intelligent network Capability Set 1 (CS1)

[ITU-T Recommendation Q.1215 (1993)]


Endorsement of documents from other standards organizations - Title

C.2.1.2 With modifications

If the endorsed document is referred to with modifications (technical and/or editorial), the title of the ETSI deliverable shall indicate that this is the case (see example).

EXAMPLE:

Endorsement of ITU-T Recommendation G.957 (1993): "Optical interfaces for equipments and systems relating to the synchronous digital hierarchy", gives the following ETSI deliverable title:

Transmission and Multiplexing (TM);
Optical interfaces for equipments and
systems relating to the Synchronous Digital Hierarchy (SDH)

[ITU-T Recommendation G.957 (1993), modified]


Endorsement of documents from other standards organizations - Title

C.2.2 Requirements
C.2.2.1 Without modifications

This element is normative and shall be entitled "Endorsement notice".

If the endorsed document is referred to without modifications, the following text should be used:

"All elements of …. apply."


Endorsement of documents from other standards organizations - Title

C.2.2.2 With modifications

If the endorsed document is referred to with modifications, one of the following text blocks should be used:

1) in the simple case where it is only required to directly modify elements of text from the endorsed document:

"The elements of …. apply, with the following modifications:"

2) in more complex cases, where (for example) additional requirements are added:

"The present document, in conjunction with ... provides the specifications for.........."

The modifications shall be presented in an order following the sequence of clauses of the endorsed document. General modifications shall precede specific modifications.

  • The use of underlining and striking out for the presentation of the modifications is recommended.
NOTE: For further details consult the endorsement skeleton (http://portal.etsi.org/edithelp/zip/ETSI_Endorsement_skeleton.zip).

OR

"The present document endorses........, the contents of which apply together with the addition of the modifications being covered herein."

In such cases, it is assumed that it will not be so easy to clearly identify the differences between the endorsed document and the endorsing document.


Endorsement of documents from other standards organizations - Title

C.2.3 Annex

Designation of the serial order of an annex shall be with two letters, the first letter always being Z (i.e. ZA, ZB, ZC, etc.), in order to avoid confusion with any annexes of the endorsed document.


Endorsement of documents from other standards organizations - Requirements

C.3 Reproduction of text from other standards organizations in endorsements
C.3.1 General and copyright

In exceptional and justified cases, it may be desired to reproduce all or part of an endorsed document, in which case the ETSI deliverable shall be drafted according to either clause C.3.2 or C.3.3, and shall take into full consideration the following copyright requirements, unless the owner of the endorsed document agrees to make the document available for easy download from a web site, the owner's, ETSI's or a third party site:

  • A signed agreement between ETSI and the organization owning the copyright of the endorsed document shall be in place.
  • The signed agreement shall permit ETSI to reproduce and make publicly available the deliverables of the other organization, either in part or in full.
  • The resulting document becomes an ETSI deliverable with ETSI copyright and it may be desired by ETSI to modify the contents of the endorsed document either at the time of initial publication or later. It is implicit therefore that the signed agreement shall permit ETSI to modify the text of endorsed documents.


Endorsement of documents from other standards organizations - Requirements

C.3.2 Inclusion without change

The ETSI deliverable (an endorsement without modification) shall be drafted in accordance with the present document, in particular in accordance with clauses C.2.1 and C.2.2.

ETSI shall not modify the endorsed document in any way and the entire unchanged PDF copy of the endorsed document shall be attached to the ETSI document.

In this case the following text should be used:

"The entire unchanged endorsed document is contained in an Adobe Portable Document Format™ file (<any_name>.pdf contained in archive <Shortfilename>.zip) which accompanies the present document."


Endorsement of documents from other standards organizations - Requirements

C.3.3 Inclusion with change

The ETSI deliverable (an endorsement with modification) shall be drafted in accordance with the present document, in particular in accordance with clauses C.2.1, C.2.2 and C.2.3.

ETSI may modify the endorsed document and the entire (modified) document shall be included in the resulting ETSI deliverable (irrespective of whether it is all or part of the document which is being endorsed).


Safety statements

Annex D Safety statements
D.1 Introduction

ETSI Technical Committee (TC) Safety is responsible for statements to be included in any ETSI deliverables regarding the protection of the health and the safety of the user and any other person.

There are several product safety standards already available from CENELEC that have been cited in the Official Journal of the European Union (OJEU) in connection with the Low Voltage Directive (LVD) 2006/95/EC. Such Harmonized Standards can be used to demonstrate compliance with some or all of the essential requirements of article 3.1(a) of the Radio equipment & Telecommunications Terminal Equipment (R&TTE) Directive 1999/5/EC (see article 18).

If it is desired to give the user of the deliverable some guidance on safety matters, the following text may be used in all ETSI deliverables (either as a separate clause or as the final element of the Scope):

"Requirements for safety are outside the scope of the present document. Safety standards are published by CENELEC. A list of relevant standards can be found at http://ec.europa.eu/enterprise/newapproach/standardization/harmstds/reflist/lvd.html".

NOTE 1: An example of such a CENELEC product safety standard is EN 60950-1.
NOTE 2: For safety categories of interfaces, see CENELEC TR 62102.

If this is done then the following shall be added to the bibliography of the ETSI deliverable:

CENELEC EN 60950-1: | "Safety of information technology equipment".
CENELEC TR 62102: | "Electrical safety; Classification of interfaces for equipment to be connected to information and communications technology networks".


Harmonized Standards - General directions

Annex E Harmonized Standards under the R&TTE
E.1 General directions

The elements necessary for the drafting of a Harmonized Standard are briefly summarized below:

a) | The Harmonized Standard shall be an EN produced in accordance with the present document.
b) | The EN shall be identified as a Harmonized Standard, the reference of which is intended to be published in the Official Journal of the European Union (OJEU) referencing the relevant Directive. This identification shall be made in the "Foreword" at "Public Enquiry" and "Vote" stage and when the standard is published by ETSI (see clause E.2).
c) | The Harmonized Standard shall have appropriate transposition periods specified. A Harmonized Standard confers presumption of conformity when it has been published in the Official Journal of the European Union (OJEU) and transposed by a member state. The Official Journal citation gives the date of cessation of presumption of conformity of a previous standard. This is usually taken to be the date of withdrawal (dow) supplied by the standardization body.
d) | The Harmonized Standard shall include all technical specifications necessary for demonstrating presumption of conformity of the products and phenomena within its scope.
e) | Methods of measurement may be included in the Harmonized Standard, or may be normatively referenced in the text.
f) | The Harmonized Standard shall contain a normative annex identifying the technical specifications with the essential requirements of the relevant Directive (see clause E.3).
NOTE: | ETSI Guide EG 201 399 gives guidance on the production of Harmonized Standards for all radio equipment and telecommunication terminal equipment under Directive 1999/5/EC (the R&TTE Directive). Furthermore, a skeleton document intended to assist the structuring and drafting such standards is maintained by editHelp! and is available on the ETSI web site( http://portal.etsi.org/edithelp/zip/ETSI_HS_EN_skeleton.zip).


Foreword of a Harmonized Standard

E.2 Foreword of a Harmonized Standard

The Foreword of a Harmonized Standard under the R&TTE Directive shall contain the following text:

The present document has been produced by ETSI in response to a mandate from the European Commission issued under Directive 98/34/EC [x] as amended by Directive 98/48/EC [y].

The title and reference to the present document are intended to be included in the publication in the Official Journal of the European Union of titles and references of Harmonized Standard under the Directive 1999/5/EC [z].

See article 5.1 of Directive 1999/5/EC [z] for information on presumption of conformity and Harmonised Standards or parts thereof the references of which have been published in the Official Journal of the European Union.

NOTE: This is one example of such text. Text for other Directives will be adapted by the ETSI Secretariat.


Annex of a candidate Harmonized Standard

E.3 Annex of a Harmonized Standard

The Harmonized Standard shall include an annex A as its first normative annex which presents a requirements table and conformance test specifications table. The annex shall conform to the following format:

Annex A (normative):
HS Requirement and conformance Test specifications Table (HS-RTT)

The HS Requirements and conformance Test specifications Table (HS-RTT) in table A.1 serves a number of purposes, as follows:

 it provides a statement of all the requirements in words and by cross reference to (a) specific clause(s) in the present document or to (a) specific clause(s) in (a) specific referenced document(s);
it provides a statement of all the test procedures corresponding to those requirements by cross reference to (a) specific clause(s) in the present document or to (a) specific clause(s) in (a) specific referenced document(s);
it qualifies each requirement to be either:
- Unconditional: meaning that the requirement applies in all circumstances; or
- Conditional: meaning that the requirement is dependent on the manufacturer having chosen to support optional functionality defined within the schedule;
in the case of Conditional requirements, it associates the requirement with the particular optional service or functionality;
it qualifies each test procedure to be either:
- Essential: meaning that it is included with the Essential Radio Test Suite and therefore the requirement shall be demonstrated to be met in accordance with the referenced procedures;
- Other: meaning that the test procedure is illustrative but other means of demonstrating compliance with the requirement are permitted.

Table A.1: HS Requirements & conformance Test specifications Table (HS-RTT)

Harmonized Standard EN <en_no> The following requirements and test specifications are relevant to the presumption of conformity under the article <art> of the R&TTE Directive [x]
Requirement |  |  | Requirement Conditionality |  | Test Specification
No | Description | Reference: clause No | U/C | Condition | E/O | Reference: clause No
1 |  |  |  |  |  |
2 |  |  |  |  |  |
(etc.) |  |  |  |  |  |

A detailed key to columns shall be provided in a suitable format in accordance with the following edited as appropriate for any specific case (see EG 201 399 for guidance). For each requirement which is must be met in order to satisfy the presumption of conformity in accordance with the relevant article of the R&TTE Directive the table shows:

a) | a sequence number purely for reference purposes, a brief textual description of the aspect and a reference to a clause where the requirement is defined precisely;
b) | a conditionality statement indicating that the requirement is essential in all cases or whether the requirement only applies if certain optional features or facilities are claimed by the supplier, in which case the conditions shall be explicitly stated;
c) | a reference to the clause where the test specification relevant to demonstrating whether the requirement has been met. Such test specifications are classified according to whether they are part of the "essential radio test suite" in the sense of the R&TTE Directive.

Clause references appearing in this table may be either to clauses within the Harmonized Standard itself or to other documents normatively referenced by the document. As far as possible, it is preferred to make direct reference to the clause specifying the requirement or test specification, rather than to a clause which merely references a further clause perhaps in another document.


References in a Candidate Harmonized Standard

E.4 References in a Harmonized Standard

See clause 12.3.


References in a Candidate Harmonized Standard

E.5 The EN title in the official languages

Prior to publication in the Official Journal of the EU, the title of a harmonized standard has to be available in all of the official languages.

NOTE :

The translated titles of Harmonized Standards are provided to ETSI by the relevant National Standards Organisation (NSO) during the public approval procedure (Public Enquiry, Vote and One-step Approval Procedure).